Production and Sandbox Environment issues
Incident Report for PremFin Status Page
Resolved
This incident has been resolved.
Posted Jan 31, 2023 - 07:23 UTC
Monitoring
Earlier today we were made aware of a technical issue affecting Mambu. Users may experience issues with login, timeouts, unexpected errors may occur. We are aware of the root-cause and are currently working to resolve the issue.

We now have a fix which is ready and is being implemented on all environments. Impact remains mitigated. No further updates are going to be provided.
Posted Dec 13, 2022 - 18:45 UTC
This incident affected: Production Environment (PremFin, Ireland) and Sandbox Environment (PremFin, Ireland).