A fix has been implemented and we are monitoring the results.
Posted Jan 31, 2025 - 17:02 UTC
Investigating
Mambu has become aware of an issue affecting PremFin Production environment. Users may be experiencing temporary service degradation. We are currently investigating the issue.
Posted Jan 31, 2025 - 10:33 UTC
This incident affects: Production Environment (PremFin, Ireland).