Possible service degradation

Incident Report for PremFin Status Page

Resolved

This has been resolved, the service should be back to usual levels.
Posted Feb 07, 2025 - 09:45 UTC

Identified

While Mambu is working on Incident 00180897 mitigation you might feel temporary service degradation including errors and delays / unavailability of UI.
Posted Feb 07, 2025 - 09:14 UTC
This incident affected: Production Environment (PremFin, Ireland).